Quick answer: The “Principal could not be found or this principal type is not supported” error in Azure SQL can occur when Azure Data Factory does not have a system-assigned managed identity enabled. Enable the managed identity first, then grant it access to the Azure SQL database.
Cause
Azure Data Factory is missing a managed identity. This can happen when you try to grant the Data Factory access to Azure SQL before its managed identity has been enabled.
Solution
Azure Data Factory can use a system-assigned managed identity to authenticate to supported Azure resources. Enable it from the Data Factory resource in the Azure portal.
Open your Azure Data Factory in the Azure portal, select Identity, turn on System assigned, and click Save. This creates the managed identity for the Data Factory.

Once the identity is enabled, grant the Data Factory managed identity the required permissions on the Azure SQL database.
Pro tips:
Learn how to access Azure SQL from Azure Data Factory using managed identity.
Visual Studio Marketplace
SSIS Catalog Migration Wizard
Extend Visual Studio with an easy way to migrate SSIS Catalog projects.
Kunal Rathi
With over 15 years of experience in data engineering and analytics, I've assisted countless clients in gaining valuable insights from their data. As a dedicated supporter of Data, Cloud and DevOps, I'm excited to connect with individuals who share my passion for this field. If my work resonates with you, we can talk and collaborate.






